Inicio > *nix, ubuntu > Configuración Proxy para Chrome en XFCE (Xubuntu)

Configuración Proxy para Chrome en XFCE (Xubuntu)

martes, 16 de febrero de 2010 Dejar un comentario Ir a comentarios

Google ChromeComo algunos ya sabrán tengo en mi “netbook” corriendo con Xubuntu, el dilema que me trae a veces usar XFCE es que muchas veces aplicativos no propios de la distribución me traen problemas.

En este caso el problema es de Chrome en realidad, ya que requiere prácticamente que se use Gnome o KDE y que se configuré la variable de proxy en estos entornos.

Lamentablemente esto no existe en XFCE, y lo mas lógico es que se haga con alguna variable de entorno del sistema (export / set), sin embargo, y por razones que yo desconozco, las aplicaciones dentro de XFCE no le hacen mucho caso a esto tampoco, y no tengo la menor idea (y no he encontrado documentación al respecto) de como cambiarlas dentro de XFCE.

Así que hay que hacer algo “cavernicola” para que chrome dentro de XFCE use un proxy.

$> sudo vi /opt/google/chrome/google-chrome

Y al final de este script de inicio de chrome, cambiamos la última línea para que se parezca a algo como:

#Linea vieja comentada, y se mantiene para cuando se desee volver a activar
#solo se tendría que comentar la línea donde se activa el proxy
#exec -a "$0" "$PROGDIR/chrome" "$@"
exec -a "$0" "$PROGDIR/chrome" "$@" --proxy-server=192.168.1.1:3128

Dentro de –proxy-server defina su servidor proxy.
Estoy de acuerdo que es una forma algo a lo “bestia” pero no conseguí una forma mejor de hacerlo, se aceptan sugerencias!

Categories: *nix, ubuntu Tags: , , ,
  1. martes, 16 de febrero de 2010 a las 15:34 | #1

    Ok justo ahora me instalé xfce4 (4.6.X) en Arch y funciona al pelo (haciendo la solucion c, la de xinitrc + startx y tener la variable en .bashrc).

    Igual no es una solución linda, es bastante cutre ..

  2. martes, 16 de febrero de 2010 a las 16:15 | #2

    Probaste con GDM? por que yo tengo definida la variable en xinitrc, bashrc y env, pero nada, que versión exacta de XFCE? pudiste comprobar que chrome realmente esté usando el proxy ? IMHO es un error de chrome que deje que sea el entorno quien defina la variable cuando los otros navegadores se dejan definir dentro del mismo navegador, al menos podrían ofrecer las dos soluciones.

  3. saymel aponte
    jueves, 6 de octubre de 2011 a las 22:14 | #3

    Buenas noches, tengo la misma configuración en mi laptop y probé con una extensión de chrome llamada Proxy Switchy! y me va muy bien

  4. lunes, 26 de marzo de 2012 a las 08:57 | #4

    Me salvate la papa gracias

  5. lunes, 26 de marzo de 2012 a las 13:55 | #5

    De nada 🙂

  6. kennedy perez
    viernes, 28 de marzo de 2014 a las 08:18 | #6

    arcaico pero muy funcional gracias

  1. Sin trackbacks aún.